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Using Timeclock Manager
This application interfaces with your biometric timeclock and provides for:














Adding Timeclocks
Setting Up the Network
Configuring Timeclock Options
Managing Employees and Departments
Managing Schedules by Employee or Department
Automatic import of time clock "punches" from connected timeclocks
Managing Paycodes
Managing Holidays
Creating a variety of standard time, attendance and wage reports
Managing Time Rules
Backing up and Restoring the Database
Automatically create time entries in Quickbooks
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Configure Timeclocks
The first time you launch Timeclock Manager, the Add New Timeclock wizard steps you through the process of connecting a
timeclock.
If you wish to add additional timeclocks, click Tools->Add New Timeclock.
Timeclocks can be connected in one of three ways:
1. On your network, using a TCP/IP address.
2. Directly to your computer, using a serial cable.
3. Disconnected with data being transferred via a USB disk.
Once a timeclock has been connected and configured, clicking Refresh Clocks loads new employees and clock punches into
the application.

Adding a New Timeclock
Click Tools->Add New Timeclock to launch the Add New Timeclock Wizard.
This wizard walks you through the process of connecting and configuring a timeclock for use with the Timeclock Manager
application.
Before you begin, you must assign an IP address to the terminal. See Network Management for instructions for setting up an
IP address for either your TouchTime II, G1 or G2 terminal.
Once this is done, you can connect your timeclock to an Ethernet network using a standard CAT 5 patch cable.
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Timeclock Network Setup
Setup is based on whether you are using a TouchTime II Setup, G2 timeclock or G1.

TouchTime II Setup
Depending on the application you are using, you will access the Microsoft configuration screens one of the following two
ways: Remotely via a VNC remote desktop tool or built-in via the Genus 2 Emulator for Touch Time II

Remote Management with VNC
The TouchTime II can be remotely controlled using a remote desktop tool such as TightVNC. Use the following passwords:




Standard Password: cmi$tt2$
View Only Password: cmi^tt2^
Control Password: cmi@tt2@

To access the Microsoft Control Panel:
1. Enter the following in the Login screen: your IP address (get this from your IT department) and the cmi$tt2$
password.
2. Bring up the Task Manager by clicking CTL-ALT-DEL.
3. Select Task Manager -> Control Panel.
You are now ready to set up the network. Proceed to Setting the IP Address on page 7.

Using the Genus 2 Emulator for Touch Time II
When initializing the TouchTime II, you will see Figure 1. Touch Desktop to display the PC desktop (Figure 2). You can now use
this unit as you would any PC touchscreen tablet.
Power Icon
Desktop
Figure 1

Control
Panel

Figure 2
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Using the Virtual Keyboard
A virtual keyboard is used for entering data.
1. To display the keyboard, from the Desktop, tap the Keyboard icon in
the bottom right of the system tray (Figure 3).
2. To close the keyboard, tap the X in the keyboard’s top-right corner
(Figure 4). To hide the keyboard, double-tap the keyboard icon in
the bottom left corner (Figure 4).

Figure 3

Figure 4

Set the IP Address
Once you have connected the unit to the switch via the Cat5E Ethernet cable, it is automatically added to your network. To
proceed, you'll need the IP address for your TouchTime II.
1. From the Control Panel (Figure 2) select Network and Sharing Center|Change Adapter Settings|Ethernet.
Note: DO NOT select Ethernet 3.

2. Double-tap the screen or right-click the mouse and select Properties.

3. Highlight your TCPIP parameter and select Properties.
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4. Fill in your static IP address and select OK.

Customize Timeclock Manager
As you did earlier on your desktop, you now need to customize the TouchTime II’s dataconfiguration file.
1.
2.
3.
4.
5.
6.
7.
8.

Click any folder on the TouchTime II’s desktop.
Click Acer (C:)->Program Files->Control Module, Inc->Timeclock Manager 3.0
Right-click dataconfiguration.
Click Properties->Security->Edit.
Highlight Users and check the Full Control box under the Allow column.
Click Apply->OK->OK.
Right-click dataconfiguration.
Click Open With->Options->Notepad.
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9. The following screen displays. You will be editing the parameters inside the red box below.

10. You will need the following company-specific information from your IT department to continue:
a. Data Source
b. User ID
c. Password
d. Initial Catalog
11. Comment out the Local Instance section by moving --> from the right side of Local Instance to the far left column
following the last line of code in the Local Instance section as follows:

12. Enter your company-specific information into the Remote Instance section. For example:

13.
14.
15.
16.

When you are done, click File on the top left corner of the screen.
Click Save.
Exit Notepad.
Double-click the Launch Timeclock icon on the Touchtime II desktop.
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17. Click the red x in the top right corner to dismiss Timeclock.

18. Restart the TouchTime II by clicking the Windows icon on the bottom of the TouchTime II desktop.

19. Click the power icon and select Restart.

20. Once the desktop displays, touch the Desktop box.

21. The main Timeclock Manager screen displays.

22. To return to the PC desktop, click Supervisor. The following screen displays. Note that only a supervisor has this
access.
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23. Click Close App.

Genus 2 Network Setup
Switch the "online/offline" switch on the back of the terminal to the "offline" position and power cycle the terminal.

Offline Mode
The Genus G2 terminal offline mode is utilized for initial setup and when any of the following options require a change:
communications, readers, security, time/date, terminal maintenance and terminal administration. To enter Offline Mode,
move the switch located on the back plate of the terminal to the left position prior to power-up. If the switch is moved while
the device is powered up, the terminal resets and enters Offline Mode. When no setup changes are required, the switch
position should be to the right for Online.

In Offline Mode, the normal power up displays occur until the Starting:Setup message appears.
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Programmable
Function Keys

Numeric keypad
Used to setup
Terminal
Parameters

Direction keys allow
user to scroll through
menus

Clear and Enter keys
are display specific.

Use the left and right arrow keys to highlight Net.

Configure the G2 Terminal
Click Net to use Network Setup to configure the Terminal’s network parameters, including DHCP, IP address, gateway, subnet
mask, DNS servers, and telnet menu.

1. Press

to advance to and highlight the enable DHCP field.
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2. Press

to Disable DHCP by un-checking the "enable DHCP" checkbox.

3. Press

to advance to the IP Address field.

4. Enter an IP Address. The cursor will automatically advance to the next IP address field as you enter the numbers.
5. Press the Tab key to advance to the subnet mask field.
6. Use the Up/Down Arrow keys to scroll through the list of available subnet masks.
7. Leave the Gateway, Primary DNS, and Secondary DNS values "000.000.000.000."
8. Use

to highlight the Apply button and press

to save settings.

9. Switch the terminal from Offline back to the Online position. After a few moments, the unit will begin to initialize.

Genus 1 Network Setup
Switch the online/offline switch on the back of the terminal to the offline position and power cycle the terminal.
Offline Mode – Setup Menu
TERMINAL INFO?
<UP><DWN><E>

Use the up/down arrow keys until you see the Network Setup menu, then press E.
NETWORK SETUP
NETWORK SETUP
<0-9><E><H>
SECONDARY DNS:
000.000.000.000

Network Setup provides the ability to configure the terminal’s network parameters, including DHCP, IP address, gateway,
subnet mask, DNS servers, and telnet menu.
Press E key to enter the network setup menu.
DISABLE DHCP
NETWORK SETUP
<UP><DWN><E><H>
ENABLE DHCP
N

Note: A fixed or static IP address is required when using the TimeClock manager software.
Use the up/down arrow keys to disable DHCP by setting the selected option to N.
TERMINAL IP
NETWORK SETUP
<0-9><E><H>
TERMINAL IP:
192.168.000.064

Assign a static IP address for your terminal. A static IP address allows the application software to connect to the terminal.
SUBNET MASK
Timeclock Manager User Guide
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NETWORK SETUP
<UP><DWN><E><H>
SUBNET MASK
255.255.255.000

Specify a subnet mask for the terminal by using the up/down arrow keys to scroll through the list of valid subnet masks.
GATEWAY IP
NETWORK SETUP
<0-9><E><H>
GATEWAY IP:
000.000.000.000

Specify a gateway address for the terminal. This entry is optional if the terminal does not need to communicate with devices
outside the immediate subnet.
PRIMARY DNS
NETWORK SETUP
<0-9><E><H>
PRIMARY DNS:
000.000.000.000

This entry is not required for the Timeclock manager software. Enter a value of "000.000.000.000."
SECONDARY DNS
NETWORK SETUP
<0-9><E><H>
SECONDARY DNS:
000.000.000.000

This entry is not required for the Timeclock manager software. Enter a value of "000.000.000.000."
ENABLE TELNET
NETWORK SETUP
<UP><DWN><E><H>
ENABLE TELNET:
Y

Enable the telnet interface to the terminal.
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TELNET PORT
NETWORK SETUP
<0-9><E><C><H>
TELNET PORT:
09999

Leave the telnet port configured for the factory default value of "9999."
TELNET PIN
NETWORK SETUP
<0-9><E><C><H>
TELNET PIN:

█

Do not assign a value for the telnet PIN.
ENABLE TFTP (Enable/Disable only)
NETWORK SETUP
<UP><DWN><E><H>
ENABLE TFTP:
Y

Ensure that the TFTP interface is enabled. This will allow you to update the terminal's application in the future.
SAVE CHANGES
NETWORK SETUP
<E><H>
SAVE CHANGES?
‘E’=SAVE ‘H’=ABORT

Saves all network changes by selecting E.
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Configure Timeclock Options
To configure the options for a timeclock:
1. Click Tools.
2. Select Timeclock Options.
3. Select the clock to configure.
The Timeclock Options dialog displays.

Timeclock Options Tab
This page displays information about the Genus timeclock, including the firmware revision, number of employees, records,
and so on. This display does not apply to the TouchTime II clock.

To update the firmware on the Genus Timeclock:
1. Click Update.
2. Select a valid firmware file.
NOTE: This process must not be interrupted!

Refresh Timeclock Data
The Refresh Clocks button pulls new employees and clock punches from all connected time clocks into the application
and Quickbooks.
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Employees and Departments
To View, Edit and Maintain Employees and Departments:
1. Click Employees.
2. Click a timeclock or department in the left pane to view the members on the right.
From here you will be able to manage your employees as follows:








Add
Add Multiple
Edit
Delete
Delete Multiple
Import
Enroll Fingerprints

From here you will also be able to Add, Edit and Delete departments.
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Adding an Employee
To add an employee:
1. Click All Employees or the specific Time Clock in the left pane.
2. Click Add.

1. The Employee Dialog box displays.
2. Enter information for the appropriate fields.
3. Click OK.
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Editing an Employee
To edit an employee:
1. Click All Employees or the specific Time Clock on the left.
2. Highlight the employee on the right side of the screen and click Edit.

1. The Employee Dialog box displays.
2. Make any necessary changes.
3. Click OK.

Timeclock Manager User Guide

May 3, 2017

19

Deleting an Employee
To delete an employee:
1. Select the Employee you want to delete in the right pane.
2. Click Delete.
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Adding a Department
To add a department:

1. Click All Employees or the specific Time Clock on the left.
2. Click Add in the left pane.

3. The Department Dialog box displays.
4. Enter a department name, and select a Pay Code using the dropdown menu.
5. Click OK.
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Editing a Department
To edit a department:
1. Double-click a department on the left side of the Timeclock Manager screen. The Department Dialog box
displays.
2. Make changes to the department name or Pay Code.
3. Click OK.
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Deleting a Department
To delete a department:
1. Highlight the department that you want to delete in the left pane.
2. Click Delete at the bottom of the left pane.
Note: Only Departments that do not contain any employees can be deleted.
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Adding to or Removing Multiple Employees from a Department
To add or remove multiple employees:
1. Click Employees.
2. Select the Department.
3. Click Employees at the bottom of the left pane.

The Select Department Employees dialog box displays.

4. Check the employees that should be members of the department you selected in Step 2.
5. Click OK.
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Enrolling an Employee Fingerprint
The process of assigning a fingerprint to an employee is called Enrollment. To enroll one or more fingerprints for an employee
you must have designated supervisor privileges at one or more timeclocks.
To setup an Employee as a supervisor:
1.
2.
3.
4.
5.
6.

Click Employees and highlight the employee you wish to designate as a supervisor.
Click Edit under the list of employees.
When the Employee dialog box opens, click the Timeclocks tab.
Select the clock(s) to designate the employee as supervisor on in the Enabled Timeclocks section.
Check the Supervisor box.
Click OK. The employee is now able to Bio Enroll user's fingerprints at Timeclocks.

To Enroll a Fingerprint at the Timeclock:
1. At the Timeclock, select either the Supv (supervisor) or BioEnroll options.
2. Enter the ID Number of the designated supervisor.
3. Use the up/down menu keys on a G1 terminal and select the Enroll option. On G2 terminals, simply enter the
employee badge number and select the Enroll key.
4. Follow the on-screen prompts and direct the employee to place their finger on the sensor when ready. CMI
recommends that you enroll 2 fingers per employee. See Using the Biometric Scan on page 26 for detailed information
about capturing a proper fingerprint.
5. Click on the Refresh Clocks option. The fingerprint data will be retrieved from the clock and stored.
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Using the Biometric Scan
Using fingerprints for identification involves the proper scanning of a user’s fingerprint from several angels to ensure a welldefined print. The Biometric scanner is located on the bottom left of the TouchTime II’s pedestal.

Ridge-lock

Biometric Definitions
Enrollment is the operation of scanning a fingerprint, determining the quality of the fingerprint scan, and storing a good
template with associated data within the memory of the scanner.
Verification is the operation of requesting the user to place their finger on the scanner, scanning the finger, comparing the
current scan against stored fingerprint templates for that user and then notification of a successful validation or a failure.
Fingerprint Template is the term used to describe the data stored on the scanner that mathematically represents the ridge
pattern of an enrolled fingerprint. This data is not the raw image of the fingerprint, but the result of processing a raw image
through our unique algorithmic process, preparing the data for later comparisons, and compressing the data for maximum
storage. An image of the uncompressed template data does resemble the raw image, but whereas a raw image is 90K bytes,
the compressed template is only 350 bytes (1 to 1) verification and 2000 bytes in a (1 to N) Identification.
Fingerprint Core is the term used to describe distinguishing print characteristics usually found in the area of the print where
the topography shows the tightest curvature. Although the entire fingerprint has significant data, the “core” is the most
data-intensive area and therefore very important.

Scanning an Image
When the scanner properly reads a fingerprint, it looks for image quality and fingerprint content. When a raw image is
collected from the sensor, the scanner searches for the fingerprint core.
Quality scores are based on how well the ridge pattern is defined within the image. For best image quality, be sure that the
sensor window is clear of dirt, residue, or other material that can block the scanner view of the fingerprint.
Once the image is scanned, the scanner then creates and stores the resulting fingerprint template.

Storing User Templates on the Biometric Scanner
Verification
The BioScan II recognizes users by matching current images to stored templates of previously enrolled fingerprints. During
VERIFICATION, a user enters their ID # and places their finger on the fingerprint capture device. The scanner will then scan
the current fingerprint and compare it against the enrolled template for that specific ID. The initial finger scan takes ~0.5
seconds and the each comparison takes ~0.5 seconds. So if the template results in a successful verification, the total time is
~1.0 seconds.

Identification
The scanner recognizes users by matching current images to stored templates of previously enrolled fingerprints. During
IDENTIFICATION, a user places their finger on the fingerprint capture device. The scanner will then scan the current
fingerprint and compare it against the enrolled templates for that specific ID. The initial finger scan takes ~20 seconds and
the each comparison takes ~1.0 seconds. So if the template results in a successful verification, the total time is ~1.0 to 2.0
seconds.
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Proper Finger Placement
The basics for successful operation of the scanner are simple but important. System performance improves dramatically with
consistent finger placement. It is important to make sure that the position of the finger allows the scanner to record the
unique features of the print. Here are the steps to follow for trouble-free fingerprint recognition.
 Use the Ridge-Lock and the Finger Guide to create “simple user instruction” and
finger position. With the fingertip raised, position the finger so that the Ridgecomfortably within the first indentation of the finger. Next, lower the finger onto
apply moderate pressure. This figure illustrates proper finger placement and the
of the scanned fingerprint.

“consistent”
Lock rests
the sensor and
resulting image

Common Mistakes
Correct finger placement is a significant component for reliable fingerprint imaging. The following figures
illustrate some common mistakes to avoid.
 Sliding the fingertip into place instead of lowering it onto the sensor will cause distortion of the
fingerprint and will degrade image quality. Keep the fingertip raised while locating the Ridge-Lock,
then lower the fingertip.
 Rotating the finger into position will also cause distortion of the fingerprint, subsequently making
verification less reliable.

 Placing your finger as if punching a button will not provide adequate information and will degrade
system performance. Proper sensor height and angle along with consistent use of the Ridge-Lock
deters this behavior.
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 Positioning the finger to one side and leaving a portion of the sensor exposed will
degrade image quality. This figure demonstrates how poor finger placement
degrades the image of the fingerprint. Notice how the core is well off-center and
the sensor is not fully covered.

 Placing the finger at an angle to the finger guide, as shown below, is another
common mistake. Rotation of the fingertip will not provide a reliable image of the
fingerprint.

 Not using the Ridge-Lock will prevent the scanner from imaging the main features
of interest. This figure illustrates the user neglecting the Ridge-Lock and resulting
fingerprint image. Notice how the core is well below center and the sensor is
not fully covered.

Image quality
Dry skin is another factor that can contribute to an unreliable image of a fingerprint. A normal amount of moisture on the skin
makes the ridges and valleys of the fingerprint stand out to the sensor. Too little moisture makes the image “noisy” and will
“cause BioScan II to reject the image during processing. Lightly moisturizing the finger will enhance the contrast of the print
and provide more reliable verification.
The increased sensitivity of the silicon sensor is dramatically reducing problems in
this area.

Image consistency
Once a user’s fingerprint template has been enrolled, the best performance in the candidate matching process depends on
consistency. Obviously, the user must use the same finger for ID verification as was used to form the original template. It is
also important to position the finger correctly for each verification, as was done when the template was enrolled, so the
scanner “sees” approximately the same information each time. Consistent use of the Ridge-Lock system and Finger Guide
ensures consistent finger placement.
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Reasons for Low Scores
Some reasons for poor sampling results are listed below:

Possible Reason

Correction

Finger movement while sampling

Instruct the user to remain still while scanner is
sampling.

Finger not positioned properly

With the fingertip raised, position the finger so that the
Ridge-Lock rests comfortably within the first indentation
of the finger. Next, lower the finger onto the sensor
and apply very moderate pressure.

User might be pressing too hard

Too much pressure on the sensor will blur the
fingerprint ridges. Allow the user to apply gentle
pressure while sampling.

User might not be pressing hard enough

You must apply gentle pressure when enrolling. The
fingerprint should lay flat upon the sensor surface.

Finger too moist or wet

If the user washed their hands, but failed to completely
dry the finger that is sampled, excessive moisture may
cause the sample to be more difficult to obtain. Dry wet
or moist fingers before sampling.

Finger too dry

Depending upon the geographical area, the season, and
the skin type of the user, their fingerprint might be
excessively rough or dry. Excessively dry skin may
affect the sample quality. Try applying skin moisturizer a
few minutes before enrolling to improve image quality.

Examples of Good and Bad Fingerprint Images

This is an example of a GOOD print. Notice that the core is well centered, the ridges are well
defined and the sensor is covered properly.
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This is an image of the Pinky (little finger). The Pinky is a BAD choice to use as a fingerprint
since the print is small compared to other fingers. As you can see, very little of the sensor
area is covered.

This is an image of the Thumb. The Thumb is also a BAD choice for fingerprint enrollment.
Although it presents a very large data area, you can see that the core is very low or even nonexistent. Do not use a Thumb for enrollment or verification

This is an example of a user not applying enough pressure. Although the core is centered, you
can see that the image coverage is very poor.

This is an example of a DRY fingerprint.
distinguishable.

Notice how the ridge pattern is very light and not well

This is an example of a WET fingerprint. Notice how the ridge pattern blurs into surrounding
ridges and the causes problems in the imaging. In this case, dry the finger of the user and
retry.

Timeclock Manager User Guide

May 3, 2017

30

Importing Employees
To Import Employees From a CSV File:
Note: Only CSV files can be imported.
1.
2.
3.
4.
5.
6.
7.

Click Employees.
Select a timeclock.
From the Main Toolbar click Employee.
From the dropdown menu, select Import then From Text File.
Navigate to the text file on your PC to import and click Open. The Import Text File dialog box displays.
Using the Field dropdown menu, select the field name to map to an appropriate position.
Using the Position numeric field, assign a position number for the field name. The chosen Field name will appear on
the column heading. Repeat Steps 6 and 7 until all fields are mapped.
8. When all fields are mapped, click OK.

9. The Import Complete dialog box displays. Click OK.
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Schedules
To Add, Edit, Copy or Delete Schedules: Click Schedules.

The list of employees and departments displays in the left pane, and a Schedule displays in the right pane.
To view the schedule for a specific date: Click the specific day in the calendar at bottom-left.
In the calendar, the current date is highlighted by the red oval, and the selected date is represented by the blue background.
You can also choose to view schedules by Day, Week or Month by clicking the corresponding button.
a schedule shown in the Week format.
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Adding a Schedule Entry
To Add a Schedule Entry:
1. Click Add.
The

Schedule Entry dialog box displays.

2.
3.
4.
5.

Select the Schedule Type using the radio buttons and dropdown menus in the Schedule Type section.
Enter the Day, Time In and Time Out for this entry in the Scheduled Time section.
Select whether this schedule repeats, and if so, until when using the Recurrence section.
Click OK.

Editing a Schedule Entry
To edit an existing schedule:
1. Select the schedule you would like to change.
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2. Click Edit.

The Schedule Entry dialog box displays.

3. Make changes.
4. Click OK.
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Deleting a Schedule Entry
To delete a schedule:
1. Select the schedule to delete.
2. Click Delete.
The Delete
Schedule Entry
dialog box displays.

3. Click OK.
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Copying a Schedule Entry to Multiple Days
It can be convenient to create a schedule for a given day, and then copy it across multiple days or weeks.
To copy a schedule:
1. Select the schedule you want to copy.
2. Click Copy.
The following
dialog displays:
(Click Cancel to
preserve existing
schedules that
might be
overwritten.)

3.
4.

Click OK to copy the schedule. A Copy Schedule dialog box appears.
Select the days the schedule is to be copied to.

5. Click OK.
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Clock Punches
To View, Add, Edit and Delete Timeclock Punches:
1. Click Clock Punches. The list of employees displays in the left pane, and the schedule display appears in the
right pane.
2. Click a date in the calendar to display clock punches for. Multiple days can also be selected to show multiple
punch days.
3. Click a specific employee to filter the list or click All Employees to display all punches.

Note: An ADJ in the Type column indicates this employee’s time was automatically adjusted according to the Rules you
set up in the Modify Time Rules section.
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Adding a Clock Punch
To Add a New Clock Punch Manually:
1.
2.
3.
4.

Click Add. The Time Transaction dialog box displays.
Enter information regarding the employee, day and time worked, Punch Type and Job Code.
If the employee has clocked out, check the box in the Time Out check box, otherwise leave it blank.
Click OK.

Editing a Clock Punch
To Edit a Clock Punch:
1. Click Clock Punches.
2. Select the punch to edit by highlighting it in the right pane.
3. Click Edit.
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The Time Transaction dialog box displays.
4. Edit the information in the Clock Punch.
5. Click OK.

Deleting a Clock Punch
To Delete a Clock Punch:
1. Click Clock Punches.
2. Select the punch to delete by highlighting it.
3. Click Delete.
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The Delete Time Entry confirmation box displays.
4. Click Ok.

Pay Codes
Pay Codes provide a way to assign hourly rates to departments or to employees. In the case where an employee is assigned a
pay code different from the one assigned to his/her department, the employee pay code is the one that is honored. Each pay
code contains hourly rates for regular pay, overtime pay and holiday pay.
To Add, Edit or Delete timeclock pay codes: Click Pay Codes.

Adding a Pay Code
To add a Pay Code:
1. Click Pay Codes.
2. Click Add.
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The Job/Pay Code dialog box displays.

3. Provide a name for the pay code in the Description field.
4. Enter all four pay rates.
5. Click OK.
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Editing a Pay Code
To Edit a Pay Code:
1. Click Pay Codes.
2. Highlight the Pay Code you want to modify.
3. Click Edit.

The Job/Pay Code dialog box displays.
4. Make any modifications needed.
5. Click OK.
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Deleting a Pay Code
To Delete a Pay Code:
1. Highlight the Pay Code you want to delete.

2. Click Delete. The Delete Pay Code dialog box displays.

3. Click OK.

Timeclock Manager User Guide

May 3, 2017

43

Holidays
Holidays are tracked for two reasons:
1. To provide scheduling (see Reports, Schedules)
2. To calculate alternate holiday pay.
To Add, Edit or Delete a Holiday: Click Holidays.

Adding a Holiday
To Add a Holiday:
1. Click Holidays.
2. Click Add.

The Holiday dialog box displays.

3. Enter the holiday’s name and date.
4. Click OK.
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Editing a Holiday
To Edit a Holiday:
1. Click Holidays.
2. Select the holiday that you want to edit and click Edit.

The Holiday dialog box displays.

3. Edit any of the fields that need changing.
4. Click OK.
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Deleting a Holiday
NOTE: When you delete a holiday, no warning message displays, so be sure you have the correct holiday selected
before clicking Delete.
To Delete a Holiday:
1. Click Holidays.
2. Select the holiday to delete.
3. Click Delete.
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Print Reports
To Print Reports:
1. Click Reports.

The Report Generator Dialog box displays.

2. Click the report in the left pane to create it. Some reports will prompt for additional information in the right
pane.
3. Use fields on the right side to provide the parameters you want to view in your report.
4. Click OK. The report displays in a separate screen.
5. On the new screen click Print. The Print dialog box displays.
6. Click OK.
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Modify Time Rules
Time Rules set particular “timeliness” parameters within the program, making time entry calculations easier to manage
and more consistent. You can modify the following rules:
 Calculations
 Gaps Between Entries
 Timeliness
 Options
To Modify Time Rules:
1. Click Rules.

The Time-Management Rules dialog box displays.

2. Make the appropriate changes. (See section descriptions below.)
3. Click OK.
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Calculations
Round time entries to the nearest X minutes: This option rounds time entries to a specific timeframe, in minutes, that
you specify. For example, in the highlighted entry below, the period between Time In (11:09 AM) and Time Out (12:50
PM) equal 1 hour and 41 minutes. Time entries are rounded to the nearest 15 minutes, and so the time column displays
1.75 hrs (1 hour 45 minutes). If no rounding is desired, set this field to 1 minute. You can see the results of this choice for
an employee’s punch time with an ADJ punch type in the Type column.

Gaps Between Entries
Gaps between entries refers to periods during the day when employees clock out temporarily, such as breaks or lunch.
The following settings determine how these breaks are labeled.




Lunch Periods fall between [time] and [time]: Breaks that cross this time period will be labeled on reports as lunch.
Consider entries with more than X hours lost or forgotten: This covers circumstances where the employee left for
the day and forgot to clock out. An ADJ punch type will appear in the Type column indicating the time worked has
been adjusted according to this formula.

Timeliness
Options in this section determine how tardiness and overtime are handled.





Grace period: Clock-ins within this number of minutes are ignored for tardiness or overtime.
Weekly overtime: Number of weekly hours before overtime pay begins.
Daily overtime: Number of daily hours before overtime pay begins.

Options



First time on schedule view: This setting affects the calendar display on the Schedule view. It sets the earliest hour
on that screen. Set this to the earliest time that your business will schedule employees.
Launching App Requires Password: Enter a password if you want to limit Time Management Rules access.
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Backup and Restore Database
Timeclock Manager runs on Microsoft SQL Server Desktop Engine, a highly robust and effective database server.
However, it is important to back up data frequently to avoid loss.
To backup time data to a file:
1.
2.
3.
4.
5.

From the main toolbar click File.
Select Backup. The Select a File to Store Database Backup dialog box displays.
Navigate to a file location and enter a backup filename.
Click Save. The backup file is created in the designated location.
When the backup is done, a message Database backup complete displays. Click OK.

Conversely, time data can be restored by clicking File -> Restore Database.

Export Data
Timeclock Manager can export Employees, Departments and Time Entries to Quickbooks.
To export data:
1. From the toolbar click File -> Export Data. The Export Data dialog box displays.

2. Select the type of data to export, the filter criteria and the destination filename.
3. Click OK.
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